Re: [OT?] Coding Style

Larry McVoy (lm@bitmover.com)
Tue, 23 Jan 2001 07:58:05 -0800


On Tue, Jan 23, 2001 at 10:41:49AM -0500, Jonathan Earle wrote:
> I prefer descriptive variable and function names - like comments, they help
> to make code so much easier to read.
>
> One thing I wonder though... why do people prefer 'some_function_name()'
> over 'SomeFunctionName()'? I personally don't like the underscore character
> - it's an odd character to type when you're trying to get the name typed in,
> and the shifted character, I find, is easier to input.

I have a tendency to use class_functionName() where "class" represents a
class of related functions. They all tend to take a point to an instance
of that "class". So then you can read the code and see the "classes" in
the names.

And, this way, I can piss off both the anti underscore and the anti mixed case
people at the same time :-)

-- 
---
Larry McVoy            	 lm at bitmover.com           http://www.bitmover.com/lm 
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/