In fact, it should be replaced by a single bit.
Passing in a "zone *" and then using it purely as a boolean makes no
But that still makes me ask: why do you have that (misnamed, and
mis-typed) boolean there in the first place? Why not just unconditionally
have the "zone_shortage(page->zone)"?
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to firstname.lastname@example.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/