I like this patch but I would change one thing.
"start,next,stop" sound like global kernel helper functions, not PCI
SEQ specific helpers, why not name them pci_seq_start et al. instead?
That pci_devices list does need locking, particularly with the PCI hot
plug stuff in the tree now. But PCMCIA could already change the list
after boot too if I'm not mistaken.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to firstname.lastname@example.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/