I'd like to be able to override a prompt.
The reason is that in general it's nice for the arch-specific Kconfig
file to include various other Kconfig files (using `source'), but
sometimes an option that usually makes sense as user-definable -- and
thus has a prompt -- _doesn't_ make sense on that particular
Currently it seems as if the arch-specific Kconfig can do several things
in this case:
(1) Inline the more general Kconfig into the arch-specific Kconfig
(with the offending option removed, and omit the `source'). This
is undesirable for all the usual reasons (code duplication causes
(2) Document somewhere that users shouldn't ever set option FOO, even
though it asks the question. This is confusing for users.
(3) Add a dependency on ARCH_BLAH or something to the definition of
FOO. This is probably the cleanest solution, but tends to result in
arch-specific knowledge being littered all over the place (though
this is already a general problem with the config system).
It would nice if I could just say in my arch-specific Kconfig:
which would force FOO to `n' regardless of any later declarations.
-- `Life is a boundless sea of bitterness' - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to email@example.com More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/