Re: [drm:drm_init] *ERROR* Cannot initialize the agpgart module.

Dave Jones (
Tue, 17 Dec 2002 13:33:07 +0100

On Mon, Dec 16, 2002 at 08:49:16PM -0500, Ed Tomlinson wrote:
> I am getting the above message in 2.5.51, 52, and 52+bk current.
> Pci info follows:
> What else would help to debug this? The drm error above is all I find in the logs...

There are a bunch of pending fixes at bk://,
but nothing that should be relevant to this problem.
Are you using agpgart as modules? Which ones loaded ?
I've a feeling agpgart.ko loaded here, but not via-agp.ko

What needs to happen is when agpgart.ko is loaded, all the
chipset drivers also get pulled in as dependancies.
Since the new module stuff went in, I'm not sure how this
works, if it works at all.[1]


[1] I'm yet another developer who has had a rough time with the
new modules stuff. I'll try it again soon.

| Dave Jones.
| SuSE Labs
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at