Re: [RFC] irq handling code consolidation, second try (v850 part)

Miles Bader (
04 Jan 2003 22:00:29 +0900

Can't test it, but the v850 part looks great, ah, it's lovely to see all
that code being deleted...

One comment: `arch_check_irq' is a bad name, it doesn't make it at all
clear what it does.

I might suggest inverting the sense, and using `irq_valid' -- the `arch_'
prefix seems unnecessary (as with `irq_desc') since it's not a
arch-specific version of a more general wrapper.



Quidquid latine dictum sit, altum viditur.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at