Re: linux-2.4.21 released

Nicolas Mailhot (
22 Jun 2003 21:46:37 +0200

This is a MIME-formatted message. If you see this text it means that your
E-mail software does not support MIME-formatted messages.

Content-Type: text/plain
Content-Transfer-Encoding: quoted-printable


Nobody replied but let me do my last report.

> I just tested with 2.4.21. With IO-APIC everything worked
> except the ethernet.

My ECS K7VTA3 5.0C is useless with Linux since I can't get
ethernet to work with IO-APIC, and without it modprobe usb-uhci
just freezes everything. It may be a broken motherboard. I
can't believe all 5.0 have so many problems, but...

...I wonder what's so different in Windows XP. As I reported
ethernet and USB work together there.


Just take a look at:
and the children bug

VIA IOAPIC/ACPI brokeness (wrt USB/ethernet) has been known and reported
for a long time (8 months at least since the initial bug reports predate
kernel bugzilla). Unfortunately that didn't stop the 2.5 changes to be
backported to 2.4, and people hit it every other week now.

(and I fear it was even removed from the 2.6 must-fix list after
figuring in a few of its versions)

Both 2.4 & 2.5 are totally broken with VIA, while 2.4-ac used to work
fine last year.


Nicolas Mailhot

Content-Type: application/pgp-signature; name="signature.asc"
Content-Transfer-Encoding: 7bit
Content-Description: Ceci est une partie de message
numériquement signée

Version: GnuPG v1.2.2 (GNU/Linux)