[an error occurred while processing this directive]
 Yliopiston etusivulle Suomeksi På svenska In English
[an error occurred while processing this directive] [an error occurred while processing this directive]
Helsingin yliopisto Tietojenkäsittelytieteen laitos
 

Tietojenkäsittelytieteen laitos

582498 Internet-protokollat / Kurssikuvaus

Asema opetuksessa

Kurssi on valinnainen erikoiskurssi Hajautettujen järjestelmien ja tietoliikenteen erikoistumislinjalla . Vanhoissa tutkintovaatimuksissa kurssi vastaa laudatur -oppimäärän kurssia Tietoliikenne II, joka on Hajautettujen järjestelmien ja tietoliikenteen erikoistumislinjan pakollinen kurssi. Näitä kahta kurssia ei voi sisällyttää samaan tutkintoon.

Tavoitteet

Kurssin tavoitteena on perehtyä Internetin toiminnan kannalta keskeisten protokollien ominaisuuksiin ja oppia ymmärtämään erityisesti verkko- ja kuljetustason protokollien toimintaa sekä niissä käytettäviä ongelmien ratkaisuperiaatteita.

Esitiedot

Kurssilla edellytetään kurssin Tietoliikenten perusteet (Tietoliikenne I) suoritus.

Suoritustavat

Kurssin voi suorittaa
  • luentokurssin yhteydessä osallistumalla aktiivisesti laskuharjoituksiin ja välittömästi kurssia seuraavaan kurssikuulusteluun.
  • tai osallistumalla erilliskuulusteluun.
Kurssi luennoidaan yleensä vain syyslukukausina (1. periodilla).
Luentokurssiin sisältyy
  • luentoja 24 tuntia (4h/vko)
  • harjoituksia 6 * 2 tuntia sekä
  • kurssikuulustelu 2,5 tuntia.

Arvosana määräytyy kurssikuulustelusta ja harjoituksista tai erilliskokeesta saatujen pisteiden perusteella (yleensä) seuraavasti

     pisteitä 30 35 40 45 50
              --------------
     arvosana  1  2  3  4  5
     

Kurssimateriaali

Kurssikirja:

Comer D. E.: Internetworking with TCP/IP, Vol. 1: Principles, Protocols, and Architecture (5th ed.), Prentice-Hall, 2006.

Kurssimateriaalina käytetään myös IETF RFC-dokumentteja (mm. RFC 793, RFC 1191, RFC 2328, RFC 2581, RFC 3782, RFC 2018, RFC 3517, RFC 2883, RFC 3042, RFC 3390, RFC 3168, ). Internet RFC:t löytyvät täältä.

Muuta kirjallisuutta:
  • James F. Kurose and Keith W. Ross: Computer Networking, A Top-Down Approach Featuring the Internet, (4. painos), Addison Wesley, 2007.
    Sisältää pääosin samat asiat, mutta hieman eri tavalla ja usein pinnallisemmin esitettynä
  • Andrew Tanenbaum, Computer Networks, (4. painos), Pearson Education, 2003;
  • William Stallings, Computer Networking with Internet Protocols and Technology. Prentice Hall 2004.
  • Christian Huitema: Routing in the Internet, (2. painos), Prentice Hall, 2000.
    Sisältää ison osan kurssin asioista: kaikki reititykseen liittyvä (RIP, OSPF, BGP, monilahetysreititys, mobiilireititys), IPv6, QoS ((Integrated Services), Resource Reservation Protocol (RSVP), eriytetyt palvelut (Differentiated Services)

Luentokalvot ja kurssin harjoitukset muodostavat tarkemman määrittelyn kurssin alueesta. Huomattakoon kuitenkin, että kalvot eivät korvaa oppikirjaaja muuta kurssimateriaalia. Ne ovat paremminkin laajennettu kurssin sisällysluettelo.

Sisältö

Käsittelyjärjestys voi poiketa alla olevasta. Katso tarkempi sisältö ja vaadittava kurrssimateriaali täältä.

  1. Johdanto
  2. IP-protokolla, ICMP, ARP, PMTUD, DHCP, CIDR, NAT
  3. TCP-protokolla: ruuhkanhallinta, uusimpia parannuksia, aktiivinen jononhallinta, suorituskyky

  4. IPv6
  5. Internet-reititys: RIP, OSPF, BGP
  6. Monilähetysreititys (Multicast routing)
  7. Liikkuvuus, Mobile IP
  8. Palvelun laatu Internetissä: Internet QOS ja Multimedian tuki Internetissä


Markku Kojo, päivitetty 3.9.2007.