[ Hopefully this mail won't be encoded in Chinese-BIG5 :-) sorry
about that ]
The only difference between your and my tree now is the PCI_MAX_DMA32
flag. Would you consider this? I already use this flag in the block
stuff, I just updated the two references you had. Maybe
PCI_MAX_DMA32_MASK is a better name.
I didn't put it into my patch becuase there is no way you can
use such a value in generic code.
What if my scsi controller's pci DMA mask is 0x7fffffff or something
like this? You don't know at the generic layer, and you must provide
some way for the block device to indicate stuff like this to you.
That is why PCI_MAX_DMA32, or whatever you would like to name it, does
not make any sense. It can be a shorthand for drivers themselves, but
that is it and personally I'd rather they just put the bits there
I am just finishing up the "death of alt_address" patch right now.
David S. Miller
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to email@example.com
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/