Re: Problems with booting from SX6000

Kjetil Nygård (
Mon, 25 Mar 2002 02:40:22 +0100

On Sun, Mar 24, 2002 at 08:41:35PM +0000, Alan Cox wrote:
> > I have problems with booting from a Promise SX6000.
> > I installed rh7.2, but the kernel cannot mount the filesystem. I get error
> > 6 on mounting the file-system. But in 'linux rescue' it manages to mount
> > the filesystems fine.
> >
> > What is wrong?
> Firstly you must have recent firmware or the supertrak and SX6000 hang when
> the module is loaded twice (as occurs when kudzu probes). Secondly you
> should upgrade to the RH 2.4.9 errata kernel ASAP to avoid other weird hangs
> under load that the newer i2o driver works around.

I have now installed the latest rh-kernel. I have also tried the 2.4.18 kernel (There should be some fixes for Promise SX6000 there). And the firmware is the newest. But still the system hangs during booting. I get the following messages:

Partition Check:
i2o/hda: i2o/hda1 i2o/hda2 i2o/hda3 i2o/hda4 < i2o/hda5 i2o/hd6 >
Loading jbd module
Journaled Block Device loaded
Loading ext3 module
Mounting /proc filesystem
Creating root device
Mounting root filesystem
Mounting: error 19 ext3
pivotroot: pivot_root(/sysroot, /sysroot/initrd) failed: 2
Freeing unused kernel memory: 224k freed
Kernel panic: no init found. Try pasing init= to kernel.

There could be spelling-errors, but else it should be all right. I have not made any changes to the system. (pure rh-7.2 install)

Kjetil Nygård

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at