Compaq Smart2 driver bug with Linux 2.4.18 and HIGHMEM ?

Luca Maranzano (
Fri, 29 Mar 2002 18:28:54 +0100


we've tryed to compile Linux Kernel 2.4.18 on a Compaq Proliant ML370 G2,
Pentium III 1.13Ghz, 1GB RAM, 2x36.4GB HD and SCSI Controller Compaq Smart2 5i,
firmware version 1.80. The problem is that if we enable the
CONFIG_NOHIGHMEM to 4GB in order to enable full 1GB support, the kernel
will panic saying that it cannot correctly access the
/dev/cciss/c0d0p1 root partition. Disabling the CONFIG_NOHIGHMEM support
all works fine.

Is this a known issue?

More info about our setup:

Debian 3.0
gcc version 2.95.4

Let me know if you need more info.


Kind regards,

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at