Re: Linux-2.5.8-pre1 fs/dquot

Martin Dalecki (dalecki@evision-ventures.com)
Thu, 04 Apr 2002 13:55:46 +0200


Looking further through the pre patch I have found the following:

diff -Nru a/fs/dquot.c b/fs/dquot.c
--- a/fs/dquot.c Wed Apr 3 17:11:14 2002
+++ b/fs/dquot.c Wed Apr 3 17:11:14 2002
...
+static ctl_table fs_table[] = {
+
{FS_NRDQUOT, "dquot-nr", &nr_dquots, 2*sizeof(int),
+
0444, NULL, &proc_dointvec},
+
{},
+};

What the heck is "dquot-nr"?

The breakup between the two abbreviations is not nice for the following reasons:

1. Invention of - is redundant becouse the whole thing is an abbreviation
anyway.

2. It violates C/perl/whatever rules for item names.

3. The order of "nr" "preposition" and the "-" after the item is not consistant
with the actual usage in application code!

The surrounding FS_NRDQUOT and nr_dquots show nicely that replacing
"dquot-nr" with "nrdquot" would fit much better and be much more consistant
with the implicite naming conventions used by programmers. Far easier
to grasp becouse there is no such thing as a disk quota of numbers...

Just nit-picking and ducking... ;-)

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/