[Coding style question] XXX_register or register_XXX

Rusty Lynch (rusty@linux.co.intel.com)
Wed, 20 Nov 2002 15:49:50 -0800


Is there an accepted standard on naming for registration functions? If have
a foo
object that other things can register and unregister with, should the
function names be:

int register_foo(&something);
int unregister_foo(&something);

- or -

int foo_register(&something);
int foo_unregister(&something);

-rustyl

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/