Re: [Coding style question] XXX_register or register_XXX

Halil Demirezen (nitrium@bilmuh.ege.edu.tr)
Thu, 21 Nov 2002 03:02:06 +0800


> Is there an accepted standard on naming for registration functions?
> If have a foo object that other things can register and unregister
> with, should the function names be:
> int foo_register(&something);
> int foo_unregister(&something);

really, that would make the entire kernel code a little
simplier to understand.
On the same way, we can say why there is not an accepted standard on
naming lock functions, such as

spinlock, rwlock and so on..

That would be more efficient to understand the code...
However, where is flexibility?

-hd
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/