2.4.19-pre4-ac1 vmware and emu10k1 problems

Malcolm Mallardi (magamo@ranka.2y.net)
Tue, 26 Mar 2002 16:06:38 -0500

The vmware modules will not compile properly under 2.4.19-pre4-ac1, or
under 2.4.19-pre2-ac2, but compile fine on their mainline kernel
counterparts. Here is the errors that I get from vmware-config.pl:

Building the vmmon module.

make: Entering directory `/tmp/vmware-config1/vmmon-only'
make[1]: Entering directory `/tmp/vmware-config1/vmmon-only'
make[2]: Entering directory
In file included from .././linux/driver.c:38:
/lib/modules/2.4.19-pre4-ac1/build/include/linux/malloc.h:4: #error
linux/malloc.h is deprecated, use linux/slab.h instead.
make[2]: *** [driver.d] Error 1
make[2]: Leaving directory
make[1]: *** [deps] Error 2
make[1]: Leaving directory `/tmp/vmware-config1/vmmon-only'
make: *** [auto-build] Error 2
make: Leaving directory `/tmp/vmware-config1/vmmon-only'
Unable to build the vmmon module.

Also, under 2.4.19-pre4-ac1, when the emu10k1 module is loaded, I get a
large amount of constant static until I rmmod it. 2.4.19-pre4's
initialization of the emu10k1 driver is fine, and when the emu10k1
driver is replaced with the latest CVS version of the emu10k1 driver,
it initializes and performs normally.

Malcolm D. Mallardi - Dark Freak At Large
"Captain, we are receiving two-hundred eighty-five THOUSAND hails."
AOL: Nuark  UIN: 11084092 Y!: Magamo Jabber: Nuark@jabber.com
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/