Re: 2.4.19-pre4-ac1 vmware and emu10k1 problems

Petr Vandrovec (
Tue, 26 Mar 2002 22:27:36 +0100

On 26 Mar 02 at 16:06, Malcolm Mallardi wrote:
> The vmware modules will not compile properly under 2.4.19-pre4-ac1, or
> under 2.4.19-pre2-ac2, but compile fine on their mainline kernel
> counterparts. Here is the errors that I get from

> /lib/modules/2.4.19-pre4-ac1/build/include/linux/malloc.h:4: #error

As always... If you are using VMware3.0, get

If you are using VMware2.0, you can try,
but please note that I'll not create any further VMware 2.0 patches,
so if you plan using VMware 2.0 on 2.5.x kernels, you can either
create patch yourself, or upgrade to VMware3, and also that this
patch is completely untested, as it does not compile under 2.5.7
at all ;-)
Petr Vandrovec

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at