Re: [RFC] kmem_cache_zalloc

Alan Cox (
Wed, 27 Mar 2002 20:17:14 +0000 (GMT)

> was "standard" in some sense :)
> I wonder if they (I can't remember who it was) will say
> "kmem_cache_zalloc is a non-standard name"...

Much more useful would be kcalloc(). That way we can put all the missing
32bit overflow checking into kcalloc and remove a lot of crud from the
kernel where we have to keep doing maths checks.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at