Re: [RFC] kmem_cache_zalloc

Pavel Machek (
Fri, 29 Mar 2002 23:17:21 +0100


> > was "standard" in some sense :)
> > I wonder if they (I can't remember who it was) will say
> > "kmem_cache_zalloc is a non-standard name"...
> Much more useful would be kcalloc(). That way we can put all the missing
> 32bit overflow checking into kcalloc and remove a lot of crud from the
> kernel where we have to keep doing maths checks.

What should kcalloc do?

(about SSSCA) "I don't say this lightly.  However, I really think that the U.S.
no longer is classifiable as a democracy, but rather as a plutocracy." --hpa
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at